AMPRnet – Vi gör verklig skillnad!

Det pratas en hel del om att amatörradio gör verklig skillnad och vi radioamatörer är duktiga på att berätta om detta för andra. Men, när det väl gäller så har vi ibland svårt att visa konkreta exempel på detta. Vi i SK3GA har dock något väldigt konkret att visa upp då vi bistod med vår utrustning under jordbävningskatastrofen i Nepal.

En annan sak vi vill lyfta är det projekt vi har kört i ett par år är den AMPRnetanslutning som vi har mot KTH (Kungliga Tekniska Högskolan) och SUNET (Swedish University Computer Network). Vi byggde ut vår del av nätet för en tid sedan med radiolänkar till Stengatan, Hudiksvall. Det var då vi gjorde vår upptäckt!

När väl radiolänkarna var uppe så stötte vi på en hel del bekymmer med att Internetadresser (url:s) inte översatts på rätt sätt. Detta med url:s med SSL/TLS. Alltså krypterad trafik på Internet.

Vi upptäckte under våra laborationer med detta att TCP-MSS blev felfragmenterat pga paketstorleken var ”fel” i routern på Stengatan. Vi kör vår AMPRnetanslutning på vår fiber via en tunnellösning där vi har vår huvudrouter i klubbstugan där gre-tunneln finns. När man kör med en gre-tunnel så packar man ju in datapaketen i mindre datapaket och man får detta fragmenteringsproblem som vi haft. Det är alltså data som försvinner i flytten kan man säga.

Hur löste vi gåtan?

Efter mycket testande, envishet och studerande av TCP-MSS av SA3BPE Henrik & SM3FT Lars tog SM3FT kontakt med W4KEL/SM4KEL Peter Löthberg och förhörde sig om saken. Och då öppnade sig himlen… För den mer insatte i Internets historia här i Sverige har man nog hört namnet Peter Löthberg många gånger. För den oinvigde är Peter den som fixade Internetanslutning för oss vanliga dödliga här i Sverige. Enkelt förklarat.

Hur ser lösningen ut?

Jo, lösningen ser ut som följande (Mikrotik RouterOS):

/ip firewall mangle

add action=change-mss chain=forward in-interface=all-ethernet new-mss=1428 passthrough=yes protocol=tcp tcp-flags=syn

add action=change-mss chain=forward out-interface=all-ethernet new-mss=1428 passthrough=yes protocol=tcp tcp-flags=syn

Ingen standard

Idag finns ingen standard för just paketstorleken 1428 bitar på subnät när man kör med tunnel så som vi gör i SK3GA. Detta kommer dock att lyftas i IETF (Internet Engineering Task Force) där vi kanske får en ny RFC för detta. Tack Peter för initiativet!

Och, vi har nu gjort verklig skillnad då vi hittat ett problem, formulerat det och lyft det till berörda instanser. Fantastiskt!

Tack!

Till sist vill jag tacka alla inblandade i denna lilla gåta som gjort att vi har lärt oss mycket nytt om hur det tekniskt fungerar bakom och under skalet på routrar och switchar. Och, att vi bidrar till utveckling och framsteg!

Vid tangenterna & 73 de SA3BPE Henrik

Posted in AMPRnet, Samhällsnytta, SK3GA, Utbildning.